Forum home Road cycling forum Training, fitness and health

Power??

KevinAKevinA Posts: 492
Hi Guys

Now this might be a very stupid question but its something that has been bugging me the last few rides.

I recently got a ceramic bottom bracket put in my Cervelo as well as upgrade to Ultegra DI2 and I have noticed that my rides have been slightly faster but my power has been way down (Measured using Garmin Vector 2 Pedals)

I decided to do a 34k loop today which includes a steady climb and not much interaction with traffic so traffic, lights wouldn't be a factor.

Todays ride my numbers were;

33.96km
123 W Weighted Average Power
25.5km/h average Speed
1:19.50 Time

Previous Ride was

34.39km
198 W Weighted Average Power
25.6 km.h Average Speed
1:20.36 Time

The bike is the same except the above changes, my weight is roughly the same but my power is quite a lot less than the previous ride.

Time is roughly the same, average speed was roughly the same. Weather conditions were roughly the same.

How come I am doing my rides in less time but power is way down?


Thanks

Posts

  • gethincerigethinceri Posts: 1,216
    What was the normalised power for each?
  • KevinAKevinA Posts: 492
    148 previous ride
    98 tonight
  • marykamaryka Posts: 748
    Powermeter definitely underreading now. Never had Vectors so no idea why, did you swap them into a new crankset I guess and not calibrate/tighten them properly or something?
  • KevinAKevinA Posts: 492
    Yes, but the mechanic done it

    I calibrated

    Not going to worry too much as I am waiting on powertap pedals.

    Thanks though, I knew something was up
  • cyclecliniccycleclinic Posts: 6,865
    Likely to be tightening torque.
    http://www.thecycleclinic.co.uk -wheel building and other stuff.
  • KevinAKevinA Posts: 492
    Thanks, will go and check and give it a tighten

    Knew my average the over day was down as I was 90k and 89 watts and knew I had pushed myself harder than that
Sign In or Register to comment.