Forum home Road cycling forum Training, fitness and health

Garmin 500 data fields.

tim_wandtim_wand Posts: 2,552
Just changed my Garmin 200 to a 500 with the idea of using the ANT + with HR and Cadence to work with virtual power on a turbo and trainerroad.

Couple of Idiot questions.

I ve not got my ANT dongle for the computer yet (should be here tomorrow). but I m keen to just try the 500 out on the bike with HR and Cadence.

I ve got the HR/Cadence and speed sensors paired no problem with the 500 head unit, but is there any data field which will show . Current speed. Average speed , Hr and Cadence.

In settings there are 3 individual data fields which I can set about 1 to 8 different parameters in. But what I d like to do is have Speed , Average Speed, Heart Rate, Cadence and Time elapsed all in one field, but I only seem to be able to get HR/ Cadence in field 3.

I ve not hooked it up to the computer at all yet as I ve not done a ride and I ve not got a dongle (I know I can transfer data via the cable, the dongle is really for the turbo)

So is it possible to have Speed , Av Speed, Time, Distance, HR and Cadence all on the same screen?

I can't do it this way direct on the head unit, is there a way to do it on the PC which will allow those data fields to display together on one screen on the Head Unit.

And also (sorry to be a pain) when I start using the Garmin and Sensors on the Turbo, which setting do I have to be on (do I just disable the GPS).

Thanks Tim

Posts

  • angry_birdangry_bird Posts: 3,782
    Yes, you can, you can choose how many screens you want, then how many each screen can then display upto 8 parameters, and can then choose them individually from a big long list including all those you've named. Fairly easy to do it on the unit too.

    Have you downloaded the full instructions from garmins website? My 500 only came with a brief startup guide thingy

    Also, yes, I just disable GPS for the turbo
  • mrdsgsmrdsgs Posts: 336
    there is no dongle for the 500. the only way to upload to Garmin connect is via the cable.
    Colnago Addict!
  • tim_wandtim_wand Posts: 2,552
    Thanks just playing about from the Flimsy booklet at the Moment.

    Will load the disc onto this laptop and then the one that's going into the "Suffercave" to run trainer road with the turbo, when the dongle comes.

    Will keep playing with it,
  • tim_wandtim_wand Posts: 2,552
    mrdsgs wrote:
    there is no dongle for the 500. the only way to upload to Garmin connect is via the cable.

    Okay take it the Dongle's Ant plus is just reading the CSC10 data and the HR data, direct to the P.C therefore acting as the head unit when on a turbo (GPS disabled)

    I was hoping when I d used the 500 on the bike for normal rides the dongle would read the data ofF the head unit for uploads to Garmin Connect, Take it I just use the data cable as with the 200 and the head unit stores all the additional data such as HR/Cadence/ GPS data for transfer.
  • I'm hijacking your thread (apologies) while there are clever Garminy people reading it, can you get your 500 to stop timing etc when you stop moving automatically? I've lost a few KMs here and there or added a lot of time to a ride by forgetting to stop it at junctions or traffic lights etc. I notice the other ones on the club run stop automatically but they seem to be 510s/800s/810s and keep forgetting to ask someone!!!
  • tim_wandtim_wand Posts: 2,552
    Page/Menu > settings > Bike settings > Auto Pause > (change from off to when stopped)

    That should do it.

    Still cant get all the data settings I want on one page. But still just playing about with the head unit. No P.C connection or disc loaded yet.
  • redveeredvee Posts: 11,921
    tim wand wrote:
    Still cant get all the data settings I want on one page. But still just playing about with the head unit. No P.C connection or disc loaded yet.

    Menu -- Spanner -- Bike Settings -- Training Pages -- Timer Pages -- User Defined, select which pages you want on/off. Select the page then choose the number of fields on each page. Once done, press the back arrow and go to a page. To change the data field on any page hold your finger on the data field for 2 seconds and it will highlight and then give you a list of categories then select the category and select a data field.
    I've added a signature to prove it is still possible.
  • Thanks!
  • tim_wandtim_wand Posts: 2,552
    redvee wrote:
    tim wand wrote:
    Still cant get all the data settings I want on one page. But still just playing about with the head unit. No P.C connection or disc loaded yet.

    Menu -- Spanner -- Bike Settings -- Training Pages -- Timer Pages -- User Defined, select which pages you want on/off. Select the page then choose the number of fields on each page. Once done, press the back arrow and go to a page. To change the data field on any page hold your finger on the data field for 2 seconds and it will highlight and then give you a list of categories then select the category and select a data field.


    Sorry If I am being really stupid here, remember I m just playing with the unit in my hand, haven't loaded any software or connected to the PC yet so I don't know if that's why the above wont work for me?

    I ve put in all my settings, Age, Gender, Weight, Statute UK etc.

    The unit is recognising Sattelites and Paired devices, (just HR at the moment as haven't fitted CSC to bike yet, but told the unit I have both, and both Icons are showing at the top and HR is working fine)

    Menu button Okay got that.

    Spanner?

    I can get to Bike settings but cant find Training pages anywhere. ( Do have training is this the same thing?)

    When in bike settings , I can get to Data fields.

    I have set it so only page One is on and 2,3 off. Set it to show 6 fields on Page one.

    I can highlight each data field but I cant change them?

    I can set a " WORKOUTS" page but only a maximum of 4 data fields, which again I can highlight but not change.

    This is a 500 not 510, don't know what to hold down for 2secs to change data field, I can only toggle between the six data fields it allows me to set on page one or 4 on workouts and Cadence and HR are not options in either.

    Once again sorry???????
  • zardozzardoz Posts: 251
    Someone else mentioned reading the manual! You can download it http://static.garmincdn.com/pumac/Edge500_OwnersManual.pdf it will answer all your questions.
  • angry_birdangry_bird Posts: 3,782
    1) Hold down page/menu until the menu pops up
    2) Scroll own to settings, press enter
    3) Bike settings, press enter
    4) Data fields, press enter
    5) Select the page, press enter
    6) Use the up and down arrows to select the number of fields you want, 0 to turn it off, press enter
    7) Use the up and down arrows to scroll between the fields, the text is highlighted by a little black box, when you're at the field you want press enter
    8 ) Scroll the big lists of parameters, press enter on the one you want in that slot
    9) Repeat 7&8 until happy for that screen.
    10) Press back, to set up another screen repeat from 5

    When you're done just keep pressing back until it takes you right out of the menus to the normal display.

    Absolutely no need for a PC connection, it's all quick and easy to do on the unit
  • tim_wandtim_wand Posts: 2,552
    Angry Bird wrote:
    1) Hold down page/menu until the menu pops up
    2) Scroll own to settings, press enter
    3) Bike settings, press enter
    4) Data fields, press enter
    5) Select the page, press enter
    6) Use the up and down arrows to select the number of fields you want, 0 to turn it off, press enter
    7) Use the up and down arrows to scroll between the fields, the text is highlighted by a little black box, when you're at the field you want press enter
    8 ) Scroll the big lists of parameters, press enter on the one you want in that slot
    9) Repeat 7&8 until happy for that screen.
    10) Press back, to set up another screen repeat from 5

    When you're done just keep pressing back until it takes you right out of the menus to the normal displa

    Absolutely no need for a PC connection, it's all quick and easy to do on the unit


    That's got it , Thanks a lot Angry Bird. your a Star
  • dw300dw300 Posts: 1,642
    redvee wrote:
    tim wand wrote:
    Still cant get all the data settings I want on one page. But still just playing about with the head unit. No P.C connection or disc loaded yet.

    Menu -- Spanner -- Bike Settings -- Training Pages -- Timer Pages -- User Defined, select which pages you want on/off. Select the page then choose the number of fields on each page. Once done, press the back arrow and go to a page. To change the data field on any page hold your finger on the data field for 2 seconds and it will highlight and then give you a list of categories then select the category and select a data field.


    ^ Instructions for Edge 800.
    All the above is just advice .. you can do whatever the f*ck you wana do!
    Bike Radar Strava Club
    The Northern Ireland Thread
  • tim_wandtim_wand Posts: 2,552
    Okay the idiots back.

    ANT+ dongle problems now.

    I know the CSC 10 Speed/Cadence sensor or Heart rate monitor are good, The 500 head unit is picking these up fine.

    The ANT+ dongle on the other hand wont find any devices,

    The ANT agent software is installed and set to "Pair with new devices"/ Enabled.

    all devices are sat right next to it and the lap top, but nadder. It wont protect any devices.

    Do they need to be transmitting a live feed? i.e do I need to be wearing the HR sensor and pedalling the bike to produce Speed Cadence signals. Surely it should just pick up the devices?
  • mrdsgsmrdsgs Posts: 336
    "there is no dongle for the 500. the only way to upload to Garmin connect is via the cable."

    Or to rephrase, my earlier reply, you cannot use a dongle with the Garmin 500
    Colnago Addict!
  • tim_wandtim_wand Posts: 2,552
    mrdsgs wrote:
    "there is no dongle for the 500. the only way to upload to Garmin connect is via the cable."

    Or to rephrase, my earlier reply, you cannot use a dongle with the Garmin 500


    Got that. What I am trying to do now is set up a laptop with an ANT dongle to receive data from a Garmin Hr strap
    HRM 1G (Shows ANT+ logo on it) and a Garmin CSC 10 speed Cadence sensor. with the eventual aim of using this data/ Metrics on a Turbo with Trainer road.

    I only mentioned the Garmin 500 head unit (this time) to show that I know the HR and Speed Cadence sensors are working okay (i.e didn't want anyone to just suggest replacing the batteries)

    So the 500 head unit is nothing to do with it/ I know this.

    I ve downloaded the ANT agent software to the lap top/ enabled pair with new devices.

    Dongle is in USB port with HR and Speed sensors sat next to it.

    Clock is showing on Icon/ second hand sweeping and a message that its searching for Devices.

    Still Nadder. Cant find either device.

    What am I doing wrong?
  • dw300dw300 Posts: 1,642
    Remove ANT+ dongle.
    Quit TR.
    Restart TR.
    Go to Devices screen and plug in dongle (hit search for dongle if necessary)
    Put on HRM!
    Once dongle is detected, click pair GSC10 and HRM again.
    GSC10 requires you press the Reset button to pair or spin the pedals so there is speed/cadence broadcasting.

    If it still doesnt work id remove all software, reset computer, check OS, Adobe Air (or whatever TR uses) is up to date, and reinstall the software again, then repeat the above. If that doesnt work then I duno.

    Chances are you arent wearing the HRM and havent woken up the GSC10 id say.
    All the above is just advice .. you can do whatever the f*ck you wana do!
    Bike Radar Strava Club
    The Northern Ireland Thread
  • tim_wandtim_wand Posts: 2,552
    Chances are you arent wearing the HRM and havent woken up the GSC10 id say
    s


    This^^^^^^^^.

    As it stands, I ve just got the Garmin ANT dongle in the lap top with Ant Agent running (searching for paired devices)

    and both sensors HR and CSC 10. sat next to it.

    Haven't tried the TR stuff yet. Sorry if I m being thick , I thought the ANT stick/ PC would just pick up the devices .

    I ve got a day off from the Kids tomorrow I ll get into the shed and set the Turbo up, the sensors on the bike and get on TR . and give it a go.
  • dw300dw300 Posts: 1,642
    Hope your shed is well anchored to the ground .. ;)
    All the above is just advice .. you can do whatever the f*ck you wana do!
    Bike Radar Strava Club
    The Northern Ireland Thread
  • tim_wandtim_wand Posts: 2,552
    I live in an old police house, its actually a pair of old holding cells so I think I ll be okay.

    If/ when I ever get this all set up, I want to start a new thread called "Show us your suffer cave"

    Some of the furniture in mine might scare a few people (except Aggieboy).

    I ve given up trying to get the Dongle on ANT agent to detect devices on the spare lap top.

    I m going to give it a go on this one now.

    I know the sensors are good as they are now fitted to the bike and working to the 500 a treat.

    Garmin really do now how to ruin a weekend. ( if your as big an Idiot as me)
  • tim_wandtim_wand Posts: 2,552
    Okay sorry guys, but this is beginning to ruin my weekend.

    I don't want to go out and spank a load of money on a turbo until I know this all works.i
    I know I can give the TR a go on 30 day no obligation but I d still need the turbo.

    Basically, I ve down Loaded Ant Agent on Both lap tops now, its installed fine and shows the Dongle looking for devices to pair with but it cant find nadder.

    I ve got my bike in the stand with the CSC 10 fitted and I wearing the HR sensor (I know these work the 500 is finding them no probs)

    I ve turned of the 500 and I m turning the cranks to produce a signal but the Ant Dongle will still not detect/pair to any devices. (new devices are enabled)

    Garmin support page is poor just says activate enable new devices.

    I really cant work out why the dongle wont find the sensors and its doing my swede in.

    Don't want to commit to buying a Turbo until I know this all works.

    Does anyone think I need a new/ different dongle, although this one shows that it is searching on Ant agent. and when I take it out the USB ant agent closes down, so it must be doing something and its a Garmin one with ANT+ logos on it.
  • NeXXusNeXXus Posts: 854
    Stop running ant agent, it's not needed
    And the people bowed and prayed, to the neon god they made.
  • tim_wandtim_wand Posts: 2,552
    dw300 wrote:
    Remove ANT+ dongle.
    Quit TR.
    Restart TR.
    Go to Devices screen and plug in dongle (hit search for dongle if necessary)
    Put on HRM!
    Once dongle is detected, click pair GSC10 and HRM again.
    GSC10 requires you press the Reset button to pair or spin the pedals so there is speed/cadence broadcasting.

    If it still doesnt work id remove all software, reset computer, check OS, Adobe Air (or whatever TR uses) is up to date, and reinstall the software again, then repeat the above. If that doesnt work then I duno.

    Chances are you arent wearing the HRM and havent woken up the GSC10 id say.
    NeXXus wrote:
    Stop running ant agent, it's not needed


    So NeXXus/DW300 if I just take the plunge and run everything through the TrainerRoad software then it will identify the Dongle and pair devices itself? No need for the Ant Agent software then? take it TrainerRoad has its own which will work with the Dongle and any ANT+ devices.

    I m going to commit anyway. TR is a 30 day trail and I can use the Turbo and Spare lap top to run "Sufferfest" if worse comes to worse. I can still take all the metrics off my 500 head unit in non GPS mode if needed.

    Wish me luck, I m sure I ve just got to MTFU and give it a go.

    Thanks everyone for your help.
  • NeXXusNeXXus Posts: 854
    tim wand wrote:
    So NeXXus/DW300 if I just take the plunge and run everything through the TrainerRoad software then it will identify the Dongle and pair devices itself? No need for the Ant Agent software then? take it TrainerRoad has its own which will work with the Dongle and any ANT+ devices.

    I m going to commit anyway. TR is a 30 day trail and I can use the Turbo and Spare lap top to run "Sufferfest" if worse comes to worse. I can still take all the metrics off my 500 head unit in non GPS mode if needed.

    Wish me luck, I m sure I ve just got to MTFU and give it a go.

    Thanks everyone for your help.
    What plunge? It's how it's supposed to be :shock: which is why you've been told that more than once :roll:
    And the people bowed and prayed, to the neon god they made.
  • dw300dw300 Posts: 1,642
    Don't think I ever installed ANT Agent .. if it's Garmin's own software I'm not surprised it's a bit flaky.
    All the above is just advice .. you can do whatever the f*ck you wana do!
    Bike Radar Strava Club
    The Northern Ireland Thread
  • tim_wandtim_wand Posts: 2,552
    What plunge? It's how it's supposed to be :shock: which is why you've been told that more than once :roll:
    As I said I ve not really got a clue with this sort of thing, I am 43 year old who got really excited by having a mileometer that clicked on the front fork drop out of my Carlton 35 years ago, so this stuff is all new to me.

    Just seemed counter intuitive that the Ant Dongle wouldn't recognise Garmin Ant devices when running the Garmin software, makes you question the kit?

    I ve got a Turbo now, Cyclops Fluid 2 and will set it all up tomorrow on Trainerroad and hopefully it will all just click in.

    I appreciate the help and patience of others (Nexxus/ DW300) and sorry If what seems simple to you has been annoying to reiterate to me. I just didn't fancy committing to nearly £300 of kit if it wasn't going to do what I wanted.

    I d convinced myself I was missing something simple or that there was something wrong with the Dongle, I geuss tomorrow will tell.

    Club run first though if the weathers decent. :D
  • tim_wandtim_wand Posts: 2,552
    tim wand wrote:
    dw300 wrote:
    Remove ANT+ dongle.
    Quit TR.
    Restart TR.
    Go to Devices screen and plug in dongle (hit search for dongle if necessary)
    Put on HRM!
    Once dongle is detected, click pair GSC10 and HRM again.
    GSC10 requires you press the Reset button to pair or spin the pedals so there is speed/cadence broadcasting.

    If it still doesnt work id remove all software, reset computer, check OS, Adobe Air (or whatever TR uses) is up to date, and reinstall the software again, then repeat the above. If that doesnt work then I duno.

    Chances are you arent wearing the HRM and havent woken up the GSC10 id say.
    NeXXus wrote:
    Stop running ant agent, it's not needed


    Great stuff. All the sensors are working A okay. dw300 I owe you a beer at least.

    Soft ware has installed.

    I was surprised to find I already had a login and user name, cant remember having set that up, but its deffo me.

    Final bit of Pain, Where / How do I tell it which trainer I ve got (Cyclops Fluid 2) and get the Torque Curve for Virtual Power workouts?

    Take it with the Cyclops Fluid 2 its better to use the Powertap setting as TR have verified this themselves against a Powertap meter?
Sign In or Register to comment.