Forum home Road cycling forum Workshop

Shimano Claris Chain Front Derailleur Rubbing

pentagonxpentagonx Posts: 15
edited September 2016 in Workshop
Apologies, I know this has been covered multiple times but was hoping to get some additional input.

As the titles suggests, I'm running a Shimano Claris 8-speed. The chain has always rubbed on the front derailleur but as it's my first bike and I knew nothing (and still know very little) I didn't know that that was what the noise was.

So after doing a bit of reading and a lot of YouTubing I made some adjustments it's not far better than it was but still not perfect.

As it's an entry level system I'm just wondering if some noise is to be expected to some degree and something to just put up with or if I need to make some more adjustments / take it to the local bike shop and get it sorted properly?

And does the rear derailleur have any effect on the front? I've not touched that.

Thanks.

Posts

  • dj58dj58 Posts: 2,186
    Hello, what bike is it, model/year and was it a new purchase from a shop or a second hand buy? What gear combinations does it rub in? Is it a double or triple crankset? Are you aware that there is a trim function on the left hand STI shifter that you can use to avoid chain rub on the front derailleur, assuming the system has been set up correctly?
  • Hi! It's a 2014 Spesh Allez. Bought new and and from memory was delivered mostly built... I think I just fixed the handlebars on and the wheels. Double crankset.

    The issue is mainly when on the big ring in front and the 2 smallest sprockets on the back. I can fix it by increasing the cable tension via the barrel adjuster but then if I shift back down to the small front ring and the largest sprocket at the back I get rubbing on the inside.

    Vaguely aware of the trim function and what it does but guess I hadn't really factored that into what I've been trying. Will have another go tomorrow....
  • k-dogk-dog Posts: 1,652
    That just sounds like a setup problem. I would start from scratch. I like when it is set so that no trim is needed on the big ring but you have it on the small ring.

    This is my method for front mech setup which gives really good results.

    So first , with the cable de-attached. Put the chain on the small front ring and biggest back cog. - Make sure to click the downshift lever into its lowest postion.

    Adjust the inner limit screw (closest to the frame on the front derailleur) so the gap is 1mm from the chain and the front derailleur's inner plate,so not rubbing on the chain.

    Clamp the cable (finger tight cable tension- not too much). Then shift the chain onto the smallest at the back, and shift the front onto the big ring. There should now be some chain rubbing on the cage if you spin the cranks.

    Then wind the inline barrel adjuster (adding more cable tension) until there is a 1mm gap between the outer cage and chain, and no chain rub. Look down at the front derailleur cage as you do it.

    Then wind the outer limit screw in until it just touches the stop. (start off with the outer limit screwed out, if its screwed in too much it wont shift up)

    Now shift the chain onto the small front ring, and the rear onto the second to last smallest cog. Then click into the front small ring trim position. Now whilst in the trim position - add more tension again with the barrel adjuster until there is no rub. Leave a gap of 2mm from the chain and the outer cage. This will eliminate any slop in the trim position and make it feel more positive to it should all be set.

    Check all gears and trim settings. Make sure the chain isnt being thrown over off the big ring.
    I'm left handed, if that matters.
  • Thank you for taking the time to respond. Will let you know how I get on...
  • Problem solved, thank you so much!
Sign In or Register to comment.