Forum home Road cycling forum Indoor training and turbo forum

Wahoo kickr snap 2017 "route mode" issues?

Tr0nc0Tr0nc0 Posts: 28
edited September 2018 in Indoor training and turbo forum
I would appreciate a feedback based on your testing experience on a Wahoo kickr snap 2017 unit.

I have recently bought a wahoo kickr snap 2017 (refurbished).
Overall it seems to be working fine except in "route mode".

Using my Wahoo Elemnt to control it, I tried to ride my usual local route (recorded on a real ride) which includes a 3mi 12% constant grade hill. Despite the unit offers some resistance according to the grade, I was able to ride the 3mi 12% segment averaging something around 20mi/h with an output wattage of less than 300 (74kg rider) :o I can usually average something like 10mi/h on that section!!

I just wanted to know whether "route mode" has some limitation in this scenario or I am facing a real issue with this unit.
I haven't had the chance to try out any platform such as Zwift and I am wondering if I could have a problem in this scenario as well.

thanks

F.

Posts

  • Tr0nc0Tr0nc0 Posts: 28
    Just an update on SW versions (latest up to date)
    Elemnt SW version: WF42-1985
    Kickr Snap SW version: 2.3.62

    Still facing the same issue, Wahoo Elemnt seems not to be able to control the Kickr in SIM mode when trying to ride a route.
    Anyone having the same issue?
    (As Wahoo support suggested I only have one paired device at a time, when I am using Elemnt every other Bluetooth device is OFF...)

    I also tried the SIM mode directly from Wahoo Fitness app.
    When I get into the SIM page and start increasing gradient I can feel proper resistance for that gradient, but then if I leave SIM page (eg go to ERG mode) and then go back to SIM page, then there is no resistance until I start increasing or decreasing gradient.

    Everything seems so erratic...If I have the chance I will try it with Zwift...I am worried I might have similar issues...
  • Hello,
    I give here the answer as I have found out from Wahoo customer service.
    The problem was that the Kicker Snap was paired through ANT rather than through BTLE.

    Repairing with BTLE solved the issue.

    Regards
Sign In or Register to comment.