Forum home Road cycling forum Road general

help (Strava) Garmin connect not syncing a ride to Strava.

tomerbaruch3187tomerbaruch3187 Posts: 6
edited May 2017 in Road general
:cry:

After a bit of help. My 800 has always been faultless and uploaded a ride to my connect via gone straight on Stava. I did a ride yesterday evning which I uploaded in two parts (my own fault) which transferred to Strava fine. Then did a club ride in the afternoon which hasn't or won't transfer.
Ive since tried uploading a new activity and the new activit went straight onto Strava but still hasn't uploaded last nights ride. So it's still paired with my connect fine?

Any ideas on what to try?

Cheers.

Posts

  • Man Of LardMan Of Lard Posts: 903
    Get the FIT file from the unit and see if it will upload to GarminConnect manually - if not, it's probably corrupted and may (or may not) be recoverable.
  • Get the FIT file from the unit and see if it will upload to GarminConnect manually - if not, it's probably corrupted and may (or may not) be recoverable.
    it's all on connect fine. Date and time of ride is fine too.
    its just dont upload the ride to strava :|
  • Man Of LardMan Of Lard Posts: 903
    Try taking the file manually from the device and importing into Strava then. These glitches happen sometimes - sometimes they resolve themselves & the automatic transfer happens, sometimes it doesn't.
  • Try taking the file manually from the device and importing into Strava then. These glitches happen sometimes - sometimes they resolve themselves & the automatic transfer happens, sometimes it doesn't.
    i know who to take it from the device but i dont know where to put the file into Strava.
    can you help me please? :)
  • onionmkonionmk Posts: 100
    I had the same problem with my 800. I uploaded 3 activities- the first went up on strava right away, the other two took a full day until they appeared. Try waiting a little longer. It's probably an error with Garmin connect or Strava.
  • Try taking the file manually from the device and importing into Strava then. These glitches happen sometimes - sometimes they resolve themselves & the automatic transfer happens, sometimes it doesn't.
    OMG its work! i did it :))))
    Thank you!
    :mrgreen:
  • KevinAKevinA Posts: 492
    Yeah me neither, it must be a syncing problem but if the rides are stored on your garmin it will upload when the issue is resolved.

    Or you can upload the file manually if you need the data urgently.
  • KevinA wrote:
    Yeah me neither, it must be a syncing problem but if the rides are stored on your garmin it will upload when the issue is resolved.

    Or you can upload the file manually if you need the data urgently.
    good to know :)
  • Ditch garmin connect. It's rubbish, unnecessary software and full of bugs - just upload directly to Strava.
  • ^the problem with directly uploading to Strava is that you can't do it using bluetooth via your phone.

    When it works, the automatic sync with Garmin Connect and upload to Strava is great. The ride is usually on Strava before I've taken my shoes off without even having to press a button.

    I've had a weird thing happen several time now with my 1000, where the time data messes up. For some reason this doesn't stop the upload to Garmin Connect, but does stop the sync to Strava. I only find out there is a time issue when I try to upload directly to strava and it prompts me to us FIT file tools to fix a time stamp issue before re-uploading.
  • AshleySAshleyS Posts: 1
    My Garmin Edge 800 has entirely ceased to sync via Garmin Express/Connect to Strava. I used to regularly have to follow the disconnect/connect method described in these threads over the past year or more, but now that has stopped working so I guess I have no choice but to abandon Strava and stick with Garmin's garbage software, groan! Can anyone suggest something I have not yet tried? And please don't send links to supposed "support" articles on Strava's site - they are imcomprehensible gibberish!
  • bobmcstuffbobmcstuff Posts: 8,057
    Can download via TCX from Connect and upload to Strava.

    Have needed to do that maybe 3 times in the ~400 rides I have on Connect, it's been generally reliable.

    If the link from Strava to Garmin is broken and you've followed the disconnect/reconnect steps, then it should work so I'm stumped. Although it might only work on new rides, so old ones on Connect might need to be manually synced.
Sign In or Register to comment.