Forum home Road cycling forum Road general

Garmin/Wiggle Warranty?

nigelgosnigelgos Posts: 168
edited November 2016 in Road general
Does anyone know what the process is likely to be for a faulty Garmin 800? I've had it from new for about 2.5 years. A bit gutted it's broken. It's failing to boot past the Garmin logo. I've tried resetting it but it doesn't seem to have helped :(

Posts

  • Not sure about warranty, but my 500 had this problem for the first time yesterday, mid ride. And my mate 500 did the same (same ride). Coincidence perhaps?

    Anyway, have you tried a reset? Just before writing the device off.

    1) Power device off.
    2) Press and hold Lap/Reset and Start/Stop.
    3) Power device on while still holding both buttons.
    4) Continue holding buttons when the Garmin "splash" screen appears.
    5) Release buttons when Garmin "splash" screen disappears.
  • noodlemannoodleman Posts: 852
    Send it to garmin and for £70 or £80 they will send you another unreliable glitch ridden product. Alternatively save yourself a lot of grief and buy yourself a wahoo elemnt. I've had seven garmin products in the past and the only ones that worked properly were the relatively simple edge 500 and the vivoactive. Edge 800 returned three times at £70 per time, fenix 2 was a complete censored from day one and the same goes for the glitchy 520. Tabs breaking, computer not recognising the device and two units failing in heavy rain showers.
    The elemnt have been superb so far and has only got better since its release with constant updates and added features. I know some people swear by garmin but I just swear at them and won't be wasting any more money on their overated unreliable devices.
    argon 18 e116 2013 Vision Metron 80
    Bianchi Oltre XR Sram Red E-tap, Fulcrum racing speed xlr
    De Rosa SK pininfarina disc
    S Works Tarmac e-tap 2017
    Rose pro sl disc
  • Good luck!
    I'm sorry you don't believe in miracles
  • dowtchadowtcha Posts: 421
    You could try to down rev the firmware. Download a previous version from garmin and rename the file GUPDATE.GCD and place in the garmin device and reboot.
  • nigelgosnigelgos Posts: 168
    Nothing has worked so far, I'm about to try a previous firmware found from here (http://gawisp.com/perry/edge/).

    EDIT:
    It seemed to do the update then get stuck in exactly the same place... it's on the Garmin splash screen whilst saying "loading maps..." at the bottom.
  • wongataawongataa Posts: 844
    Have you tried deleting al the maps off the unit and removing the SD card?
  • slowbikeslowbike Posts: 8,476
    I bust my 800 a few years back. I can't remember the original fault - but it wasn't a warranty claim - after phoning Garmin and paying £70 to £80 - sending back my duff unit, they sent an out of warranty replacement.
    The out of warranty replacement was ok to start with but quickly suffered power button failure - given that these are refurb units it's not surprising that parts fail. Garmin initially wanted to charge me for another out of warranty replacement but I pursuaded them that they should replace that one FOC as it was too soon having received the replacement unit. They did and since then (touch wood) I've had no issue.

    Wife broke her 810 - knocked it off the mount and it smashed on the road - same replacement service.

    Garmin are a pita to get hold of - you wait for ages on the phone and they don't respond to email - but once you get into the returns process it works quickly.
  • nigelgosnigelgos Posts: 168
    Thanks for everyone's suggestions. I think I have it working, though I've not tested it in anger yet.

    Here is what I did for anyone stumbling across this.

    In summary you force it into mass storage mode and run chkdsk /r on it.

    1) Connect your cable to the PC and Garmin.
    2) Hold down Lap/Restart and the Power button together, when the power comes on you can release the power button but keep hold of the Lap/Restart button until your computer beeps in recognition that it has detected a mass storage device.
    3) Take a note of the drive letter that the unit has been allocated by opening 'Computer' and looking at the drive letter next to your named Garmin device.
    4) Open a command prompt by pressing the windows key and typing 'cmd' and hitting enter.
    5) Type the letter name given to your unit and colon, e.g. 'e:' and hit enter.
    6) Now type 'chkdsk /r' and hit enter.

    Once finished, safely unplug your garmin and turn it off and on again. Mine then booted as normal.

    I hope this helps someone.
  • StillGoingStillGoing Posts: 5,153
    I've had 5 Garmin devices (705x2, 810x2 and current 820). Garmin refurb/replacement on the 705 and 810 were fine and problem free so there are users out there who have no problems with Garmin. 705 was old and well out of warranty. My 810 came from Israel via the internet and I applied for a replacement direct to Garmin which they dutifully did hassle free and without quibble. The 810 only needed replacing because I hadn't disconnected it from the iMac properly and the machine wouldn't detect it again. PC just needed a reboot and nothing actually wrong with the 810 I later learned.
    I ride a bike. Doesn't make me green or a tree hugger. I drive a car too.
Sign In or Register to comment.