Forum home Road cycling forum Road general

Mac not recognising Garmin 800

meesterbondmeesterbond Posts: 1,240
edited April 2018 in Road general
Anyone else having a similar problem?

Updated my MacBook to OS X El Capitan the other day and now it won't recognise my Edge 800 or Forerunner 220 through USB - both are charging ok but trying to upload into Training Peaks or Strava neither device come up in the Finder dialogue box. Both were working just fine before I upgraded so I'm guessing that's the issue but can't find anyone having similar issues online.

Any ideas?


  • I have had some problems with this.

    A couple of times I have had to reboot the mac. Mostly though I have just unplugged from the mac and then plugged back in again. It is a pain though. I have a new macbook pro.
  • Ever since I went from Garmin 510 to 520, the Macbook and iMac no longer auto load my rides.

    I have to pick out the Garmin manually, then go to Activities and find that days ride to upload.

  • mfinmfin Posts: 6,726
    Are you running Garmin Express v4.1.7.0 ?
  • meesterbondmeesterbond Posts: 1,240
    Did a bit more digging and apparently there's a known bug with 10.11 that can stop external USB drives being recognised by the mac.

    A simple reboot :oops: fixed it for me but thought I'd repost here in case anyone else had a problem. In some instances the actual USB port seems to need remapping but frankly that's beyond me.
  • earthearth Posts: 934
    I have not updated OSX from version 10.6. Garmin Connect/Express no longer supports that version of the OS so I can't use the connect to device feature of Strava. Instead I choose upload file and browse to the location of files on the Garmin. It's no great hardship and when I was in Mallorca I could use this approach on the PC in the hotel lobby.
  • Bit sluggish, to display but so far the Garmin Touring and the OSX10.11 have played nice with one notable exception, the first time I rebooted after updated, and it didn't load the garmin/card
  • pblakeneypblakeney Posts: 24,590
    A simple one-off reboot after the "official" reboots seems to work.
    The above may be fact, or fiction, I may be serious, I may be jesting.
    I am not sure. You have no chance.
    Veronese68 wrote:
    PB is the most sensible person on here.
  • robbo2011robbo2011 Posts: 1,017
    Yes, I had this problem after upgrading, but a reboot seemed to solve it.
  • I was using the wrong cable!! Resetting my Mac; powering off unit; nothing worked... until I noticed the cable wasn't the black one with "Garmin" logo moulded onto the end lug. This cheapo re-charging cable for another gadget (not requiring data transfer) presumably didn't have all the necessary connections!
  • Brilliant, welcome to the forum
    I'm sorry you don't believe in miracles
Sign In or Register to comment.