Forum home Mountain biking forum MTB general

Garmin Edge Touring ....not liking it !

cube1961cube1961 Posts: 76
edited September 2014 in MTB general
We'll third time out with this and I don't like it , I've set it to start a lap but I'd done 5 miles and it was saying I've done 1.45 ml ? Reading the sparce instruction manual and I,m still none the wiser. I've checked on U tube for a tutorial but found nothing .
All I can think is that it could be faulty ? Any ideas

Posts

  • stubsstubs Posts: 5,001
    Have you connected it to the computer and downloaded the updates off the Garmin site. I had to do that with my Garmin Dakota before it would get a satellite lock it kept saying I was in the middle of the Pacific.
    Fig rolls: proof that god loves cyclists and that she wants us to do another lap
  • Done that thanks ..... It's giving distance in Ft for some reason ?
  • njee20njee20 Posts: 9,613
    It does until it gets to about 0.2 miles, when it switches to miles.

    Has it got a decent satellite lock? Are you putting it somewhere with a good view of the sky (ie not chucking it in a bag etc)?
  • Yes on my handlebars ..... Thanks I've done a reset so will try it again next weekend and I'll report back
    Thanks guys !
  • oxomanoxoman Posts: 8,825
    Can't fault mine, never had an issue to be honest.
    Too many bikes according to Mrs O.
  • njee20njee20 Posts: 9,613
    If that doesn't work it sounds faulty. Should lock on within a few seconds, IIRC it supports GLONASS to improve accuracy. You may get a bit of dropping out in really thick tree cover, but on the road I find that manifests itself as a slight drop in speed momentarily, and that's about it!
Sign In or Register to comment.