Shimano Sora front shifter won't work at all

Nindog1404 Posts: 3
edited July 2013 in Workshop
I'm a complete beginner on the road cycling scene and recently purchased a bike from a friend. When I took it for a spin I realised that the front shifter was doing absolutely nothing. You can push it as far as it goes and still no movement on the front derallieur at all. One of my friends said he'd check it out for me but couldn't really pinpoint what it was. He said that he thought the tension seemed fine and that it could have been one of the components or something. I bought the bike anyway because I thought it would be quite an easy fix and would keep me occupied anyway!

When I got it home, another friend of mine with more experience than myself came round and looked at it. From what I can remember, he took apart the shifter, re-adjusted the cable and just generally fiddled around with it and it appeared to work - the chain was finally moving across the chainset! He did say however that I appeared to have a double chainset but three gear settings? I don't know if this is common or not?

Anyway, it was going great for a couple of weeks until last week I tried shifting it to the smaller ring and it completely went again. No movement at all.

I'm now back at square one and the friend is now in Romania so I have no one around to call on for expertise!

Is anyone able to give me some sort of instruction/direction that might allow me to fix it myself? I'd rather that and save my money instead of taking it into a shop...

Here is a link to pretty much the same bike as mine: ... elID=35559

Sorry for the super long post, I hope someone can help a newbie in distress!



  • Had this happen on a Tiagra shifter a few years ago. Same thing, worked for a bit, then nothing. Fiddled with it, did all the usual cable tension and mech settings but nothing. In the end i took it to the LBS and they confirmed the shifter was f*cked internally and needed replacing.

    New one worked a charm.
  • I was thinking this would be the case! Hoping I can find a way of botching it up again though before forking out for a new one... Wishful thinking I expect