Forum home Commuter cycling forum The workshop

Loud squeak from Pedal area.

WirralWirral Posts: 8
edited May 2011 in The workshop
Hi all, hope you can help me!?
When I apply pressure to my pedals, ie when standing up to add power or setting off from traffic lights, I get a series of creaks and squeaks from the area of the pedals. Do you have any ideas?
I don't think it is the pedals.

thanks
David

Posts

  • motopattermotopatter Posts: 179
    Remove the crank arms and clean spotlessly, reassemble. (special tool required - crank extractor)
    Check for play in the BB - any movement in the crank arms when fully tightened?
    Double check the pedals are tight and clean re-grease. (14mm? spanner)

    Nothing else but the above if it's coming from that area as far as I'm aware
    wave your willy here !!!! :)
  • Blue MeanieBlue Meanie Posts: 495
    Err, that's a 15mm spanner, or maybe 8mm allen key.
    SPD's? Apply a light squidge of grease to cleat interface too.
    :)
    FCN16 - 1970 BSA Wayfarer

    FCN4 - Fixie Inc
  • rolf_frolf_f Posts: 15,959
    I had this last week. I thought it was the cleats but it turned out to be the chain - a brand new one but clearly not much lubricated at the factory.
    Faster than a tent.......
  • FlyingbogeyFlyingbogey Posts: 352
    I have had an almost identical problem yesterday. Following a thorough clean, i went a bit ott with the de greaser and a toothbrush, re lubed evrything (I think) now when out of the saddle left pedal on the downstroke i get such a loud graunching its shuddering through the forks, problem dissapears when sitting. It got better as ride went on and had just about ceased entirely at the end of 35 miles. I really should find out a bit more about the bike!
    Bianchi Nirone C2C FCN4
Sign In or Register to comment.