Forum home Road cycling forum Road beginners

Garmin 705 problems

StillGoingStillGoing Posts: 5,207
edited September 2010 in Road beginners
I put my Garmin on charge before going away for a long weekend. Today I've gone to use it and it won't power on. Anyone else experienced anything like this with Garmin? I'm hoping it's just fried the battery and nothing more serious.
I ride a bike. Doesn't make me green or a tree hugger. I drive a car too.

Posts

  • sungodsungod Posts: 15,257
    try a hard reset...

    hold down the mode button, then press the on button, keep holding down the mode button, give it 30 seconds, if it wakes up, release the mode button, when prompted choose "yes" to clear data
    my bike - faster than god's and twice as shiny
  • i would try a soft reset first, press the mode and reset buttons together for about five secs, let go and then try the power button,if this doesnt work try a hard reset as Sungod has suggested, this works on the 305 i assume the 705 is the same,this not powering up happens sometimes after recharging.you can use this soft reset method to turn off the edge if the power button doesnt work, this happens sometimes when ive been out in sub zero temps,switching off this way doesnt lose any data.
  • StillGoingStillGoing Posts: 5,207
    I'll give them both a try. Cheers guys.
    I ride a bike. Doesn't make me green or a tree hugger. I drive a car too.
  • StillGoingStillGoing Posts: 5,207
    Nope neither of those worked. I've just e-mailed Garmin's technical department to see if there's an answer.
    I ride a bike. Doesn't make me green or a tree hugger. I drive a car too.
  • StillGoingStillGoing Posts: 5,207
    It would appear this is world wide problem with the 705 after trying to download an upgrade. The Garmin forum has a fix using webupdater but it only works with some devices. I'm one of the unlucky ones so I guess it will be wanging it's way to Garmin UK for exchange.
    I ride a bike. Doesn't make me green or a tree hugger. I drive a car too.
  • redveeredvee Posts: 11,922
    What firmware you using on you 705?

    Settings --> System --> About Edge.
    I've added a signature to prove it is still possible.
  • StillGoingStillGoing Posts: 5,207
    redvee wrote:
    What firmware you using on you 705?

    Settings -->
    System --> About Edge.
    I don't know it won't switch on. Garmin UK have asked for it to be sent to them and say it sounds terminal. An exchange will be offered if it can't be fixed.
    I ride a bike. Doesn't make me green or a tree hugger. I drive a car too.
  • dodgydodgy Posts: 2,890
    redvee wrote:
    What firmware you using on you 705?

    Settings --> System --> About Edge.

    :lol::lol:
Sign In or Register to comment.