Forum home Road cycling forum Workshop

Front Mech being awkward

BunnehBunneh Posts: 1,329
edited May 2009 in Workshop
My little Ribble bike needed a change of handlebars, the previous ones had actually corroded and were a little dangerous. So I picked up some new bars, some fresh tape, and thought a new set of cables would be nice for the little fella.

Having been out of the repairing bikes game for a good 15 years I looked at the front mech with some concern, there are little screws I wasn't used to seeing. It's a Campag Veloce front mech, but its age is unknown.

Stripping the old cables off and threading the new ones on I found the the front mech was insanely hard to move with the shifter. Yes the cable was tight and the shifter on the lowest setting, but it just wouldn't budge. I then found the messing with those aforementioned screws made this somewhat easier and the mech moved back and forth quite easily...however... The has mech started to catch the right crank and the chain is also slipping off. I've readjusted the mech so it no longer catches the right crank, but the chain still drops off and occasionally the mech is unbelievably hard to move.

I guess it's due to the front mech moving to far across, thus pushing the chain off but I cannot seem to get it working right at all. In frustration I swore at it and dumped the poor bike back under the stairs. I haven't set up a front mech in years so I'm hoping someone here can talk me through it; tutorials would be nice too :)

Thanks muchly.

Posts

Sign In or Register to comment.