Forum home Mountain biking forum MTB workshop & tech

hope mono mini's how to soften grip pressure.

kpr1969kpr1969 Posts: 112
edited April 2008 in MTB workshop & tech
just got new bike and the rear brake seems to be tight. No give at all, as soon as any movement on lever, brake is tight on. Is there a way of altering this as rear wheel seems to be permanently under braking...i.e. when I lift back wheel off ground and pedal the wheel comes to a stop as if under light braking..

thanks

Posts

  • Drfabulous0Drfabulous0 Posts: 1,539
    Your bike hasn't been set up properly, take it back to the shop and insist they sort it out.
  • kpr1969kpr1969 Posts: 112
    bought it 2nd hand
  • Will SnowWill Snow Posts: 1,154
    check out parktools!!! www.parktools.com
    i ride a hardtail
  • kpr1969kpr1969 Posts: 112
    Shimano, avid an hayes seems to be covered by park tool...hope site not specific to my problem either.
  • Will SnowWill Snow Posts: 1,154
    ok what year is it??? i.e. is it black or silver??? the chances are youll need to lever open the pads, by sticking a flat screwdriver or similar in the gap and GENTLY levering them apart. pump the lever a few times (with the rear whell in!!!) and that should sort it. if not, then it gets more important about what year the brakes are...
    i ride a hardtail
  • kpr1969kpr1969 Posts: 112
    bike is a 2005 so i'm guessing the brakes are of that year.
    Black with the gold/bronze pot
  • Will SnowWill Snow Posts: 1,154
    right, so theyll be post mounts... did you try opening the pads apart??
    i ride a hardtail
  • kpr1969kpr1969 Posts: 112
    seemed to work on the front brake...travels quite freely now with just a slight bit of rub but the rear is like riding with the brakes applied..
  • stu8975stu8975 Posts: 1,334
    You might have a sticky piston or two, i had one on my '07 mono minis. I took my pads out, inserted something between the pistons so you can open the back up (i used a knife blade ), then squeeze the brake until the pistons come out more than usual, apply a very small amount of grease around the piston, then open them back up with knife blade, insert pads and give the lever a few pulls to work the grease in...no more sticky pistons..job done
  • I had the aluminium pistons partly seize in my Hope mini monos. It sounds like that's what has happened to yours.
    You could try forcing them back in then pumping them back out a few times to see if that frees them up, but if the aluminium is corroded it is likely to damage the seals.
    You could take the pistons out, clean up the outer surface and refit them.
    Or you could just take the opportunity to upgrade to phenolic pistons like I did.
    I am a mountain biking god.
    Unfortunately, my bike's an atheist.
  • kpr1969kpr1969 Posts: 112
    been in touch with the previous owner and he says they probably need bleeding. He says he hasn't bled them for over 12months. Could this be it?
  • grantwaygrantway Posts: 1,430
    Your brakes have not been set/bleed properly

    Take back to the shop and ask to show you how they do it for
    future references.
  • kpr1969kpr1969 Posts: 112
    bought from private seller..thats what I wanted to hear though...
Sign In or Register to comment.