Forum home Mountain biking forum MTB workshop & tech

Disc brake adjustments, can anyone help me?!

JayKingFunkJayKingFunk Posts: 411
edited February 2008 in MTB workshop & tech
I just fitted the a new Avid BB7 mechanical disc brake to my front forks. I followed the instructions for installation and for some reason my pads are rubbing slightly.

If i back them off using the adjusting controls on the brake then i loose all the gripping power. The instructions tell you to push the inside pad up to the rotor 1/3 distance from it then adjust the outer pad so its 2/3's distance from the rotor. This locks the rotor completely so you can tighten the brake mounts.

Then it says to adjust the pads away from the rotor to get the correct clearance. The instructions suggest it should only take 2 or 3 turns on the adjuster controls but I'm having to turn them loads to stop them catching and then there's no grip! Should i be adjusting where the cable goes through the torque arm on the brake instead of the discs??

It doesn't catch the rotor all the way round either, only slightly in the same place each time. The wheel is brand new and doesn't look at all buckled in any way.

Is it normal to have a bit of rubbing because its new or am i doing something wrong??

Much appreciation in advance for your help!
I love the sound my tyres make on dusty single track!

Posts

  • AnonymousAnonymous Posts: 79,692
    Check youve got the wheel set in the dropouts correctly.
  • mattvmattv Posts: 992
    Quite often you get a bit of rubbing. Does it slow the wheel down if you lift the bike and spin it?
Sign In or Register to comment.