Forum home Road cycling forum Road beginners

Front Mech Help

ChoggerChogger Posts: 62
edited May 2015 in Road beginners
Hi I'm still fairly new to all this. I went out for a ride on the weekend and my front mech wouldn't work properly dropping down from the big ring to the small ring it would just stay in the same position for a bit then eventually change with a heavy clunk after a bit dropping the chain off on a couple of occasions. I got home played around with it for a bit on the stand and everything appeared to be working fine but I went for rid e this morning and the same thing was happening again.
Any advice appreciated to try and resolve this issue thanks.

The bike has a shimano sora 9 speed groupset which I know isn't the greatest but suits my needs at the moment.

Posts

  • rafletcherrafletcher Posts: 1,160
    Disconnect the cable and see if the mech is free to pivot. If yes, replace the cable. If no, clean or replace the mech - and the cable!.
  • ChoggerChogger Posts: 62
    Thank you will try this when I get home tonight.
  • KajjalKajjal Posts: 3,404
    Also oil the 4 pivots on the front mech and do a few shifts to work the oil in. Make sure it is clean before doing this.
  • trailflowtrailflow Posts: 1,311
    Check the cage isn't catching on the large front chainring. It should be 2-4mm above the chainring.
  • doug5_10doug5_10 Posts: 465
    Rubbish shifting big - small is also an indication of too much cable tension, check your indexing.
    Edinburgh Revolution Curve
    http://app.strava.com/athletes/1920048
Sign In or Register to comment.