Forum home Road cycling forum Workshop

Brakes jamming on rim (Shimano 105)

rodgers73rodgers73 Posts: 2,626
edited September 2014 in Workshop
My rear brakes wont return to the open position after braking, sometimes completely jamming on the rim, other times one pad will rub.

It feels like something needs greasing but I'm bot sure if I should be stripping them down and doing this or doing some other sort of work on them.

Any ideas???

Posts

  • rolf_frolf_f Posts: 16,015
    You don't say anything about age of components and what sort of riding you do so it is a bit hard to second guess what the problems might be but I'd start first with trying to work out for certain what is at fault. Eg for example, you could remove the cable from the caliper and attach the cable to a spare caliper (the front one if that's the only one you have!) - if the brake then works perfectly, you know that the problem is with the rear caliper - if it doesn't then you know that the rear caliper is not guilty.

    If it isn't the caliper, remove the cable from the outers and inspect. If it looks ok, it probably is in which case the cable outers are probably knackered so buy new. If the cable looks knackered, replace it and see if that improves the situation. One or both should solve the problem if it isn't the caliper at fault.

    If it is the caliper at fault, then just taking it off and repeatedly compressing it and opening it beyond the normal cable controlled limits might help but really you are probably better off attacking the bearings with release agents, GT85, oil etc. If that doesn't work, pull the thing apart, clean and reassemble. If you have an ultrasonic cleaner, this is a good use for it before or after dismantling the brakes.
    Faster than a tent.......
  • rodgers73rodgers73 Posts: 2,626
    Oh its quite new - was fitted in Febuary

    I'll give your ideas a go - never really messed about with mechanicals before now!
  • rolf_frolf_f Posts: 16,015
    Brakes new as well? If the caliper is at fault and fairly new I'd potentially want to talk to the shop about it. Either way, it should be possible to get it back to life without dismantling it unless you are unlucky. I think my sticking front Campag caliper is probably worn in the bushings - no amount of dismantling and cleaning seems to get it back to A1 condition.

    Anyway, welcome to the world of fettling. You'll be building your own bike before you know it!
    Faster than a tent.......
  • oxomanoxoman Posts: 9,023
    If your struggling on anything mechanical on your bike there is a youtube video that will cover it. Saved me some grief and I have learnt to pretty much do all my own work.
    Too many bikes according to Mrs O.
  • Monty DogMonty Dog Posts: 20,614
    99% certainty due to dirty or damaged cables - far less likely is due to brake calipers. Remove the cable and compress the caliper to see if it springs back smoothly. Clean/relube or replace the brake cable. Make sure the underside of the caliper isn't caked in gunk too.
    Make mine an Italian, with Campagnolo on the side..
  • rodgers73rodgers73 Posts: 2,626
    As soon as I cut the cable and removed it the calipers freed up nicely. Changed the cable and put a new outer length on the rear section and it worked fine again. Other than being forced to buy a decent pair of cable cutters this has been a pleasant and cheap(ish) learning curve!
  • rolf_frolf_f Posts: 16,015
    Great stuff! All you need to do now is take the same approach next time something goes wrong and you need never (almost) bother a bike shop for repairs again!
    Faster than a tent.......
Sign In or Register to comment.