Forum home Road cycling forum Road general

Pee'd off with my Garmin 705!

JSCLJSCL Posts: 1,259
edited May 2013 in Road general
Hey guys,

Just wandering if any of you guys (and gals) could help out here, having some serious issues with my Garmin Edge 705.

It's simply not being recognised when plugged in to USB on PC or Mac (yes, I've tried three different cables) - I've tried following suggestions online to reformat but it threw an error up saying "Unable to format" on the PC. I know you can force the egde in to data mode, which I have, but it merely recognises the SD card and not the data on the edge itself.

So I'm left with a few rides on there that I desperately wish to export and I'd like to get this issue fixed (if I can). Any suggestions please?
Follow me on Twitter - http://twitter.com/scalesjason - All posts are strictly my personal view.

Posts

  • Have you tried switching it off and back on again?
    I'm sorry you don't believe in miracles
  • itboffinitboffin Posts: 19,576
    Yep i had this with mine, sent it back to Garmin for a replacement. It was a faulty USB connector port
    Rule #5 // Harden The censored Up.
    Rule #9 // If you are out riding in bad weather, it means you are a badass. Period.
    Rule #12 // The correct number of bikes to own is n+1.
    Rule #42 // A bike race shall never be preceded with a swim and/or followed by a run.
  • flasherflasher Posts: 1,620
    This is a common fault, you need to send it back.
  • Celt100Celt100 Posts: 22
    Sometimes trying a different port on the PC works I have issues too with certain IT hardware but switching to using a rear PC usb port sometimes will solve the issue.
  • Yep - me too! I plug the device in, hit upload and Garmin Connect informs me that there is no device recognised. I have better luck when I connect the Garmin to the computer and then open up Garmin Connect and upload.
  • ScotterScotter Posts: 52
    I`ve just sent my Edge 800 back to Garmin for the same fault.

    I rode a 112 mile sportive in non stop rain on sunday and the unit faulted mid ride. I think damp may have got in via the loose fitting USB port cover. When I got home, it wouldn`t connect to my laptop.

    My unit is 14 months old and so out of warranty, but I rang Garmin who thankfully said they will replace it with an as-new, re-conditioned unit free of charge, so at least I`m not going to be out of pocket. Their service has been first class.
    You will need to ring them first to get an RMA number before you send it back.

    I believe, from what I`ve read online, the USB cover is better fitting on the units now. I also think it may be worth spraying a light coating of some kind of water repellent into the port, to prevent it happening again.

    Hope this helps :wink:
Sign In or Register to comment.