Elite Parabolic Rollers - problem

redvision
redvision Posts: 2,958
edited May 2013 in Workshop
Have a problem with my elite rollers and was just wondering if anyone has had a similar issue?

I bought these brand new in November. Have used them roughly once a week since then, usually doing about 30miles at a time on them, so they havent really had a great deal of use.

Last night when on them i started getting a strange feeling through the back wheel. Almost like the roller wasnt round.
Thinking maybe it was an issue with the tyre/wheel or bike itself i jumped off and looked but couldnt see or hear any issues with either. Then checked the roller itself and it seemed to spin ok, although there was a slight grinding noise occasionally coming from it (bearings i presume), and the belt was fine.

Anyway, to rule out the bike i switched to my race bike but exactly the same thing happened. No matter what speed i was doing the rear wheel feels like its on something uneven and the ride becomes very uncomfortable.

Its still under warranty and wiggle have been great and arranged a collection next week for inspection, just annoying that this has happened.

So just wondering if anyone has had a similar issue?
How long did it take to be repaired?
Is it likely to happen again?

Thanks

Comments

  • schweiz
    schweiz Posts: 1,644
    The only problem I've had with my elite e-motion is that the plastic rollers are seem to get damaged by heat. I put my bike on the rollers once and the rear wheel was spinning and that burnt in one groove and then a few more have been burnt as a result of losing concentration and stopping quickly to stop myself from falling off. The rollers look messy but there's no grating.

    Hope wiggle come good for you.
  • Monty Dog
    Monty Dog Posts: 20,614
    Are they the Elite V-Arion Intertial rollers? I've got a set too and they can made a bit of a racket at a certain speed. Had mine apart to see what problem is, couldn't see anything - I think it's just a function of the intertial mechanism - speed-up a bit and they go quiet again.
    Make mine an Italian, with Campagnolo on the side..
  • redvision
    redvision Posts: 2,958
    Thanks for the replies.

    The rollers are just the basic elite parabolic and so dont have resistance.

    I tried them again tonight and the noise is like a thud and the faster you go the faster it gets, although no louder.
    Have tried switching the belt to the opposite side but noise persists. Have also tried both of my bikes on them and both cause the noise, so its definitely the rollers.
    Upon close inspection tonight the middle roller does look very slightly out of shape when you watch the end of it (end wobbles very slightly). So im assuming this is part of the problem.

    Anyway, they are being returned on monday so will hopefully get them sorted.
    Just going to be frustrating being without them (especially given the forecast for the next week).

    Will let you know what wiggle say.
  • Is this the Paris-Roubaix edition?
    :lol:
    All the gear, but no idea...
  • Just a thought, but I had a similar issue with a set of Tacx rollers. It turned out that one of the bolts for the middle roller was just a little loose.

    Have you checked to make sure everything is nice and tight?
  • redvision
    redvision Posts: 2,958
    just thought i would post an update on the roller problem.

    wiggle contacted me today to say they have inspected the rollers and agree there is an issue and they aren't safe to ride. however, they say they were unable to locate what is causing the uneven sensation and the noise and so have had to send it to the manufacturers for further inspection
  • I have the same rollers, bought the same month, from Wiggle. Whilst mine are not dangerous (I have done over 1500 miles), they do vibrate (both front and middle) on any surface (with a good mat). It is certainly not enough to make me feel unsafe, or put me off using them, though it is a little noisier than I feel it should be.

    A mate of mine bought the same rollers from a club member, and he is experiencing the same.

    Could you keep us updated as and when you get an answer back from Elite?

    Thanks.
  • redvision
    redvision Posts: 2,958
    Funkhau53r wrote:
    I have the same rollers, bought the same month, from Wiggle. Whilst mine are not dangerous (I have done over 1500 miles), they do vibrate (both front and middle) on any surface (with a good mat). It is certainly not enough to make me feel unsafe, or put me off using them, though it is a little noisier than I feel it should be.

    A mate of mine bought the same rollers from a club member, and he is experiencing the same.

    Could you keep us updated as and when you get an answer back from Elite?

    Thanks.

    Had a response last night from them, apparently there was a bearing issue which has been replaced. The rollers are on there way back to me and due to be delivered today!
    Fingers crossed its sorted.

    Quite impressed with both wiggle and elite for sorting the problem pretty quick (reported issue 3 weeks ago).