Forum home Road cycling forum Workshop

Problems shifting up the gears

curiumcurium Posts: 815
edited August 2011 in Workshop
Hi

I'm riding a specialized tricross sport 2009 with tiagra shifters and deore LX derailleur.

Due to a recent accident I've swapped the 11-32 for a 12-23.

I've adjusted the B-screw and set the H and L screws.

I've indexed the gears starting from the smallest sprocket and it shifts down the gears nicely.

The problem comes when i'm coming back up the gears. Often the chain won't move from the 21T to the 19T unless I click up again in which case it then jumps down 2 sprockets to the 17T cog.

I'm wondering if the cable is sticking somewhere but there is very little outer cable for it to stick to. The cable is exposed all the way down the down-tube and under the chain-stay so there is only the loop from the chain-stay into the derailleur and from the shifter to the downtube.

I'm considering changing the derailleur as it's had a few knocks but that's for another thread...

Posts

  • TwostageTwostage Posts: 987
    Try lubing everything possible on the rear derailleur, something might be gunked up which is causing it to be sluggish.
  • First thing to do is to check that the gear hanger is plumb. If you have had an accident then it's likely to be bent and no amount of adjustment will help the indexing.
  • curiumcurium Posts: 815
    First thing to do is to check that the gear hanger is plumb. If you have had an accident then it's likely to be bent and no amount of adjustment will help the indexing.
    I should of mentioned above that I have replaced the derailleur hanger today as previously when I indexed the gears the lower pulley was striking the spokes when using the 21T cog! :shock:
Sign In or Register to comment.